#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?ms)(^NAME.*?)^\s+^\d"
Local $sString = "SQL*Plus: Release 11.2.0.1.0 Production on Wed Jan 27 13:46:07 2016" & @CRLF & _
"" & @CRLF & _
"Copyright (c) 1982, 2010, Oracle. All rights reserved." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Connected to:" & @CRLF & _
"Oracle Database 11g Enterprise Edition Release 11.2.0.3.0 - 64bit Production" & @CRLF & _
"With the Partitioning, Real Application Clusters, Automatic Storage Management, OLAP," & @CRLF & _
"Data Mining and Real Application Testing options" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"NAME" & @CRLF & _
"--------------------------------------------------------------------------------" & @CRLF & _
"Agent-Job Follow Up Missed Group D" & @CRLF & _
"Agent-Job Follow Up Missed Group E" & @CRLF & _
"Audit Archive" & @CRLF & _
"Day BGO - 705 and 705NA - A (2)" & @CRLF & _
"Day BGO - ERR Quebec - A" & @CRLF & _
"Dispatch Lunch Break Agent (Pre-Agent) - Group D" & @CRLF & _
"Helper Job Agent (Amend, Prevent, Lead) Group A" & @CRLF & _
"Incomplete Tasks Display Status Cleanup - Group A" & @CRLF & _
"Jeopardy Agent (Late EnRoute, OnSite, Complete) Group A" & @CRLF & _
"Jeopardy Agent (Late EnRoute, OnSite, Complete) Group B" & @CRLF & _
"Lunch Break Report Agent(Post-Agent) - Group A" & @CRLF & _
"" & @CRLF & _
"NAME" & @CRLF & _
"--------------------------------------------------------------------------------" & @CRLF & _
"MST Validation - Group A" & @CRLF & _
"MST Validation - Group C" & @CRLF & _
"Unschedule INHS Tasks" & @CRLF & _
"Unschedule Jobs with Schedule Update Failure - Group E" & @CRLF & _
"" & @CRLF & _
"15 rows selected." & @CRLF & _
"" & @CRLF & _
"Disconnected from Oracle Database 11g Enterprise Edition Release 11.2.0.3.0 - 64bit Production" & @CRLF & _
"With the Partitioning, Real Application Clusters, Automatic Storage Management, OLAP," & @CRLF & _
"Data Mining and Real Application Testing options"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")