package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\w+)\s-\s(?P<goalscorer>.+)\s\((?P<assist1>.+),\s(?P<assist2>.+)\)\s*$`)
var str = `CHI - J.Toews (H.Sedin, D.Sedin) `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}