re = /^(\w+)\s-\s(?P<goalscorer>.+)\s\((?P<assist1>.+),\s(?P<assist2>.+)\)\s*$/
str = 'CHI - J.Toews (H.Sedin, D.Sedin) '
# Print the match result
str.match(re) do |match|
puts match.to_s
end