package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([2-9]|[1-4][0-9]|50)$`)
var str = `51
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}