use strict;
my $str = '192.168.0.160';
my $regex = qr/\d+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";