import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![0()-]+$)\\(?(\\d{3})\\)?[-. ]?(\\d{3})[-. ]?(\\d{4})$";
final String string = "(222)-333-4444\n"
+ "(010)-123-3435\n"
+ "(100)-454-6565\n"
+ "(000)-000-0000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}