$re = '/^(?![0()-]+$)\(?(\d{3})\)?[-. ]?(\d{3})[-. ]?(\d{4})$/m';
$str = '(222)-333-4444
(010)-123-3435
(100)-454-6565
(000)-000-0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);