$re = '/(\s\b.{1,2}\b)\s/';
$str = 'Maja i jej przyjaciel Gucio polecieli na śniadanie.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);