re = /(\s\b.{1,2}\b)\s/
str = 'Maja i jej przyjaciel Gucio polecieli na śniadanie.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end