#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(?:\D*\d\D*){8,14}$)[ -]*\+?[ -]*(?:\((?:[ -]*\d)+[ -]*\))?[- \d]*"
Local $sString = "12345678901234" & @CRLF & _
"123 456789 0 1 2 3 4" & @CRLF & _
"+1 2345678901234" & @CRLF & _
"(12) 3 4 56 7 8 9 01234" & @CRLF & _
"1-2-3-4-5-6-7 8 9 0 123 4" & @CRLF & _
"1-2-3-4-5-6-7 8 9 0 123 47"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")