import re
regex = re.compile(r"^(?=(?:\D*\d\D*){8,14}$)[ -]*\+?[ -]*(?:\((?:[ -]*\d)+[ -]*\))?[- \d]*", flags=re.MULTILINE)
test_str = ("12345678901234\n"
"123 456789 0 1 2 3 4\n"
"+1 2345678901234\n"
"(12) 3 4 56 7 8 9 01234\n"
"1-2-3-4-5-6-7 8 9 0 123 4\n"
"1-2-3-4-5-6-7 8 9 0 123 47")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")