$re = '/\d{0,}\.(\d{0,})/';
$str = '0.6666666666666666';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);