const regex = new RegExp('([A-Za-z0-9_]+?)[ ]?(?:\\(([A-Za-z0-9=\\-\\/°% ]*)\\))?_([A-Za-z0-9]*)$', 'gmi')
const str = `name (unit)_type
name(unit)_type
long_name_type
name_type`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}