re = /([A-Za-z0-9_]+?)[ ]?(?:\(([A-Za-z0-9=\-\/°% ]*)\))?_([A-Za-z0-9]*)$/mi
str = 'name (unit)_type
name(unit)_type
long_name_type
name_type'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end