#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\s*"[^"]+")"
Local $sString = ""sound_materials"" & @CRLF & _
"{" & @CRLF & _
" "common"" & @CRLF & _
" {" & @CRLF & _
" "value" "0"" & @CRLF & _
" "start_drag_sound" "ui.inv_pickup"" & @CRLF & _
" "end_drag_sound" "ui.inv_drop"" & @CRLF & _
" "equip_sound" "ui.inv_equip"" & @CRLF & _
" }" & @CRLF & _
" "chest"" & @CRLF & _
" {" & @CRLF & _
" "value" "1"" & @CRLF & _
" "start_drag_sound" "ui.inv_pickup_chest"" & @CRLF & _
" "end_drag_sound" "ui.inv_drop_chest"" & @CRLF & _
" }" & @CRLF & _
" "pennant"" & @CRLF & _
" {" & @CRLF & _
" "value" "2"" & @CRLF & _
" "start_drag_sound" "ui.inv_pickup_pennant"" & @CRLF & _
" "end_drag_sound" "ui.inv_drop_pennant"" & @CRLF & _
" }" & @CRLF & _
" "key"" & @CRLF & _
" {" & @CRLF & _
" "value" "3"" & @CRLF & _
" "start_drag_sound" "ui.inv_pickup_key"" & @CRLF & _
" "end_drag_sound" "ui.inv_drop_key"" & @CRLF & _
" }" & @CRLF & _
" "metal_small"" & @CRLF & _
" {" & @CRLF & _
" "value" "4"" & @CRLF & _
" "start_drag_sound" "ui.inv_pickup_metalsmall"" & @CRLF & _
" "end_drag_sound" "ui.inv_drop_metalsmall"" & @CRLF & _
" "equip_sound" "ui.inv_equip_metalsmall"" & @CRLF & _
" }" & @CRLF & _
" "metal_armor"" & @CRLF & _
" {" & @CRLF & _
" "value" "5"" & @CRLF & _
" "start_drag_sound" "ui.inv_pickup_metalarmour"" & @CRLF & _
" "end_drag_sound" "ui.inv_drop_metalarmour"" & @CRLF & _
" "equip_sound" "ui.inv_equip_metalarmour"" & @CRLF & _
" }" & @CRLF & _
" "metal_blade"" & @CRLF & _
" {" & @CRLF & _
" "value" "6"" & @CRLF & _
" "start_drag_sound" "ui.inv_pickup_metalblade"" & @CRLF & _
" "end_drag_sound" "ui.inv_drop_metalblade"" & @CRLF & _
" "equip_sound" "ui.inv_equip_metalblade"" & @CRLF & _
" }" & @CRLF & _
" "metal_heavy"" & @CRLF & _
" {" & @CRLF & _
" "value" "7"" & @CRLF & _
" "start_drag_sound" "ui.inv_pickup_metalheavy"" & @CRLF & _
" "end_drag_sound" "ui.inv_drop_metalheavy"" & @CRLF & _
" "equip_sound" "ui.inv_equip_metalheavy"" & @CRLF & _
" }" & @CRLF & _
" "staff_or_blunt"" & @CRLF & _
" {" & @CRLF & _
" "value" "8"" & @CRLF & _
" "start_drag_sound" "ui.inv_pickup_staff"" & @CRLF & _
" "end_drag_sound" "ui.inv_drop_staff"" & @CRLF & _
" "equip_sound" "ui.inv_equip_staff"" & @CRLF & _
" }" & @CRLF & _
" "robes"" & @CRLF & _
" {" & @CRLF & _
" "value" "9"" & @CRLF & _
" "start_drag_sound" "ui.inv_pickup_robes"" & @CRLF & _
" "end_drag_sound" "ui.inv_drop_robes"" & @CRLF & _
" "equip_sound" "ui.inv_equip_robes"" & @CRLF & _
" }" & @CRLF & _
" "leather"" & @CRLF & _
" {" & @CRLF & _
" "value" "10"" & @CRLF & _
" "start_drag_sound" "ui.inv_pickup_leather"" & @CRLF & _
" "end_drag_sound" "ui.inv_drop_leather"" & @CRLF & _
" "equip_sound" "ui.inv_equip_leather"" & @CRLF & _
" }" & @CRLF & _
" "quiver"" & @CRLF & _
" {" & @CRLF & _
" "value" "11"" & @CRLF & _
" "start_drag_sound" "ui.inv_pickup_quiver"" & @CRLF & _
" "end_drag_sound" "ui.inv_drop_quiver"" & @CRLF & _
" "equip_sound" "ui.inv_equip_quiver"" & @CRLF & _
" }" & @CRLF & _
" "stone"" & @CRLF & _
" {" & @CRLF & _
" "value" "12"" & @CRLF & _
" "start_drag_sound" "ui.inv_pickup_stone"" & @CRLF & _
" "end_drag_sound" "ui.inv_drop_stone"" & @CRLF & _
" "equip_sound" "ui.inv_equip_stone"" & @CRLF & _
" }" & @CRLF & _
" "wood"" & @CRLF & _
" {" & @CRLF & _
" "value" "13"" & @CRLF & _
" "start_drag_sound" "ui.inv_pickup_wood"" & @CRLF & _
" "end_drag_sound" "ui.inv_drop_wood"" & @CRLF & _
" "equip_sound" "ui.inv_equip_wood"" & @CRLF & _
" }" & @CRLF & _
" "bone"" & @CRLF & _
" {" & @CRLF & _
" "value" "14"" & @CRLF & _
" "start_drag_sound" "ui.inv_pickup_bone"" & @CRLF & _
" "end_drag_sound" "ui.inv_drop_bone"" & @CRLF & _
" "equip_sound" "ui.inv_equip_bone"" & @CRLF & _
" }" & @CRLF & _
" "jug"" & @CRLF & _
" {" & @CRLF & _
" "value" "15"" & @CRLF & _
" "start_drag_sound" "ui.inv_pickup_jug"" & @CRLF & _
" "end_drag_sound" "ui.inv_drop_jug"" & @CRLF & _
" "equip_sound" "ui.inv_equip_jug"" & @CRLF & _
" }" & @CRLF & _
" "gun"" & @CRLF & _
" {" & @CRLF & _
" "value" "16"" & @CRLF & _
" "start_drag_sound" "ui.inv_pickup_gun"" & @CRLF & _
" "end_drag_sound" "ui.inv_drop_gun"" & @CRLF & _
" "equip_sound" "ui.inv_equip_gun"" & @CRLF & _
" }" & @CRLF & _
" "highvalue"" & @CRLF & _
" {" & @CRLF & _
" "value" "17"" & @CRLF & _
" "start_drag_sound" "ui.inv_pickup_highvalue"" & @CRLF & _
" "end_drag_sound" "ui.inv_drop_highvalue"" & @CRLF & _
" "equip_sound" "ui.inv_equip_highvalue"" & @CRLF & _
" }" & @CRLF & _
"}"
Local $sSubst = "\1:"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)