# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\s*\"[^\"]+\")"
test_str = ("\"sound_materials\"\n"
"{\n"
" \"common\"\n"
" {\n"
" \"value\" \"0\"\n"
" \"start_drag_sound\" \"ui.inv_pickup\"\n"
" \"end_drag_sound\" \"ui.inv_drop\"\n"
" \"equip_sound\" \"ui.inv_equip\"\n"
" }\n"
" \"chest\"\n"
" {\n"
" \"value\" \"1\"\n"
" \"start_drag_sound\" \"ui.inv_pickup_chest\"\n"
" \"end_drag_sound\" \"ui.inv_drop_chest\"\n"
" }\n"
" \"pennant\"\n"
" {\n"
" \"value\" \"2\"\n"
" \"start_drag_sound\" \"ui.inv_pickup_pennant\"\n"
" \"end_drag_sound\" \"ui.inv_drop_pennant\"\n"
" }\n"
" \"key\"\n"
" {\n"
" \"value\" \"3\"\n"
" \"start_drag_sound\" \"ui.inv_pickup_key\"\n"
" \"end_drag_sound\" \"ui.inv_drop_key\"\n"
" }\n"
" \"metal_small\"\n"
" {\n"
" \"value\" \"4\"\n"
" \"start_drag_sound\" \"ui.inv_pickup_metalsmall\"\n"
" \"end_drag_sound\" \"ui.inv_drop_metalsmall\"\n"
" \"equip_sound\" \"ui.inv_equip_metalsmall\"\n"
" }\n"
" \"metal_armor\"\n"
" {\n"
" \"value\" \"5\"\n"
" \"start_drag_sound\" \"ui.inv_pickup_metalarmour\"\n"
" \"end_drag_sound\" \"ui.inv_drop_metalarmour\"\n"
" \"equip_sound\" \"ui.inv_equip_metalarmour\"\n"
" }\n"
" \"metal_blade\"\n"
" {\n"
" \"value\" \"6\"\n"
" \"start_drag_sound\" \"ui.inv_pickup_metalblade\"\n"
" \"end_drag_sound\" \"ui.inv_drop_metalblade\"\n"
" \"equip_sound\" \"ui.inv_equip_metalblade\"\n"
" }\n"
" \"metal_heavy\"\n"
" {\n"
" \"value\" \"7\"\n"
" \"start_drag_sound\" \"ui.inv_pickup_metalheavy\"\n"
" \"end_drag_sound\" \"ui.inv_drop_metalheavy\"\n"
" \"equip_sound\" \"ui.inv_equip_metalheavy\"\n"
" }\n"
" \"staff_or_blunt\"\n"
" {\n"
" \"value\" \"8\"\n"
" \"start_drag_sound\" \"ui.inv_pickup_staff\"\n"
" \"end_drag_sound\" \"ui.inv_drop_staff\"\n"
" \"equip_sound\" \"ui.inv_equip_staff\"\n"
" }\n"
" \"robes\"\n"
" {\n"
" \"value\" \"9\"\n"
" \"start_drag_sound\" \"ui.inv_pickup_robes\"\n"
" \"end_drag_sound\" \"ui.inv_drop_robes\"\n"
" \"equip_sound\" \"ui.inv_equip_robes\"\n"
" }\n"
" \"leather\"\n"
" {\n"
" \"value\" \"10\"\n"
" \"start_drag_sound\" \"ui.inv_pickup_leather\"\n"
" \"end_drag_sound\" \"ui.inv_drop_leather\"\n"
" \"equip_sound\" \"ui.inv_equip_leather\"\n"
" }\n"
" \"quiver\"\n"
" {\n"
" \"value\" \"11\"\n"
" \"start_drag_sound\" \"ui.inv_pickup_quiver\"\n"
" \"end_drag_sound\" \"ui.inv_drop_quiver\"\n"
" \"equip_sound\" \"ui.inv_equip_quiver\"\n"
" }\n"
" \"stone\"\n"
" {\n"
" \"value\" \"12\"\n"
" \"start_drag_sound\" \"ui.inv_pickup_stone\"\n"
" \"end_drag_sound\" \"ui.inv_drop_stone\"\n"
" \"equip_sound\" \"ui.inv_equip_stone\"\n"
" }\n"
" \"wood\"\n"
" {\n"
" \"value\" \"13\"\n"
" \"start_drag_sound\" \"ui.inv_pickup_wood\"\n"
" \"end_drag_sound\" \"ui.inv_drop_wood\"\n"
" \"equip_sound\" \"ui.inv_equip_wood\"\n"
" }\n"
" \"bone\"\n"
" {\n"
" \"value\" \"14\"\n"
" \"start_drag_sound\" \"ui.inv_pickup_bone\"\n"
" \"end_drag_sound\" \"ui.inv_drop_bone\"\n"
" \"equip_sound\" \"ui.inv_equip_bone\"\n"
" }\n"
" \"jug\"\n"
" {\n"
" \"value\" \"15\"\n"
" \"start_drag_sound\" \"ui.inv_pickup_jug\"\n"
" \"end_drag_sound\" \"ui.inv_drop_jug\"\n"
" \"equip_sound\" \"ui.inv_equip_jug\"\n"
" }\n"
" \"gun\"\n"
" {\n"
" \"value\" \"16\"\n"
" \"start_drag_sound\" \"ui.inv_pickup_gun\"\n"
" \"end_drag_sound\" \"ui.inv_drop_gun\"\n"
" \"equip_sound\" \"ui.inv_equip_gun\"\n"
" }\n"
" \"highvalue\"\n"
" {\n"
" \"value\" \"17\"\n"
" \"start_drag_sound\" \"ui.inv_pickup_highvalue\"\n"
" \"end_drag_sound\" \"ui.inv_drop_highvalue\"\n"
" \"equip_sound\" \"ui.inv_equip_highvalue\"\n"
" }\n"
"}")
subst = "\\1:"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.