$re = '/(?:.*?HALL.*?){2,}/';
$str = 'HALL #1 HALL #2 HALL #3';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);