$re = '/^[0-9]{5}_([\w-]+)_[0-9]{4}[-_][0-9]{2}[-_][0-9]{2}[-_][0-9]{2}[:_][0-9]{2}[:_][0-9]{2}\.dat$/m';
$str = '12345_arbitrarystring_2020_05_20_10_10_10.dat
12345_ar_bitra-rystring_2020_05_20_10_10_10.dat
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);