re = /^[0-9]{5}_([\w-]+)_[0-9]{4}[-_][0-9]{2}[-_][0-9]{2}[-_][0-9]{2}[:_][0-9]{2}[:_][0-9]{2}\.dat$/m
str = '12345_arbitrarystring_2020_05_20_10_10_10.dat
12345_ar_bitra-rystring_2020_05_20_10_10_10.dat
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end