package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:\([^)]*\)|\S+))`)
var str = `(I want) some ice cream
I want some ice cream`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}