re = /^((?:\([^)]*\)|\S+))/m
str = '(I want) some ice cream
I want some ice cream'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end