$re = '/^.*\d\s+(.*?)$/m';
$str = '-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);