re = /^.*\d\s+(.*?)$/m
str = '-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml
-rw-r--r-- 1 admin staff 460340057 May 4 14:19 test_large_file.xml'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end