import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+$\\n";
final String string = "278\n"
+ "00:15:13,442 --> 00:15:14,436\n"
+ "Mr. Burns,\n\n"
+ "279\n"
+ "00:15:14,454 --> 00:15:17,893\n"
+ "I came here because my brother\n"
+ "is about to be wrongfully convicted,\n\n"
+ "280\n"
+ "00:15:17,947 --> 00:15:19,514\n"
+ "and the man I'm looking for\n\n"
+ "281\n"
+ "00:15:19,542 --> 00:15:21,010\n"
+ "would help me find the truth.\n\n"
+ "282\n"
+ "00:15:21,038 --> 00:15:21,907\n"
+ "Don't you get it?\n\n"
+ "283\n"
+ "00:15:21,932 --> 00:15:23,918\n"
+ "I don't care who you are\n"
+ "or what you want.\n\n"
+ "284\n"
+ "00:15:25,167 --> 00:15:26,801\n"
+ "Now get lost.\n\n"
+ "285\n"
+ "00:15:29,102 --> 00:15:31,170\n"
+ "I think you just sent away\n"
+ "the first person\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}