import re
regex = re.compile(r"^\d+$\n", flags=re.MULTILINE)
test_str = ("278\n"
"00:15:13,442 --> 00:15:14,436\n"
"Mr. Burns,\n\n"
"279\n"
"00:15:14,454 --> 00:15:17,893\n"
"I came here because my brother\n"
"is about to be wrongfully convicted,\n\n"
"280\n"
"00:15:17,947 --> 00:15:19,514\n"
"and the man I'm looking for\n\n"
"281\n"
"00:15:19,542 --> 00:15:21,010\n"
"would help me find the truth.\n\n"
"282\n"
"00:15:21,038 --> 00:15:21,907\n"
"Don't you get it?\n\n"
"283\n"
"00:15:21,932 --> 00:15:23,918\n"
"I don't care who you are\n"
"or what you want.\n\n"
"284\n"
"00:15:25,167 --> 00:15:26,801\n"
"Now get lost.\n\n"
"285\n"
"00:15:29,102 --> 00:15:31,170\n"
"I think you just sent away\n"
"the first person\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")