const regex = /(\S+)\/wp-content\/uploads\/(?:0\d|1[0-2])\/\d{4}\/(\S+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S+)\\\/wp-content\\\/uploads\\\/(?:0\\d|1[0-2])\\\/\\d{4}\\\/(\\S+)', 'g')
const str = `domain.com/wp-content/uploads/05/2020/image.jpg
domain.com/wp-content/uploads/13/2020/image.jpg`;
const subst = `$1/$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);