import Foundation
let pattern = #"(\S+)\/wp-content\/uploads\/(?:0\d|1[0-2])\/\d{4}\/(\S+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
domain.com/wp-content/uploads/05/2020/image.jpg
domain.com/wp-content/uploads/13/2020/image.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1/$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)