#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""[^"]*"|(;)"
Local $sString = "STOPATDESK YES;" & @CRLF & _
":: TXT "LCLLMT:29.4700";" & @CRLF & _
":: TXT "LCLCURR;NON-USD";" & @CRLF & _
":: TXT "CALLBK:3";" & @CRLF & _
":: ;TXT "FFTRL:EUR-LIM;-TAP-5";" & @CRLF & _
"" & @CRLF & _
"STOPATDESK YES; :: TXT "LCLLMT:29.4700"; :: TXT "LCLCURR;NON-USD"; :: TXT "CALLBK:3"; :: TXT "FFTRL:EUR-LIM;-TAP-5";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")