import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"[^\"]*\"|(;)";
final String string = "STOPATDESK YES;\n"
+ ":: TXT \"LCLLMT:29.4700\";\n"
+ ":: TXT \"LCLCURR;NON-USD\";\n"
+ ":: TXT \"CALLBK:3\";\n"
+ ":: ;TXT \"FFTRL:EUR-LIM;-TAP-5\";\n\n"
+ "STOPATDESK YES; :: TXT \"LCLLMT:29.4700\"; :: TXT \"LCLCURR;NON-USD\"; :: TXT \"CALLBK:3\"; :: TXT \"FFTRL:EUR-LIM;-TAP-5\";";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}