#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xsu)(?(DEFINE)" & @CRLF & _
" (?P<realEnd>" & @CRLF & _
" (?(3)\>)" & @CRLF & _
" (?(4)\))" & @CRLF & _
" (?(5)\])" & @CRLF & _
" (?(6)\})" & @CRLF & _
" (?(7)\7)" & @CRLF & _
" )" & @CRLF & _
")" & @CRLF & _
"#Ограничитель 1" & @CRLF & _
"((\<)|(\()|(\[)|(\{)|" & @CRLF & _
"((?=[[:ascii:]])[^\s\w\\\)\]\}\>]))" & @CRLF & _
"#Шаблон" & @CRLF & _
"(" & @CRLF & _
" (?:" & @CRLF & _
" \\. | # что-то экранированое ИЛИ" & @CRLF & _
" [\w\d\s]++ | # литералы, которые не могут быть ограничителем ИЛИ" & @CRLF & _
" (?!(?P>realEnd)). # что угодно кроме ограничителя" & @CRLF & _
" )*+" & @CRLF & _
")" & @CRLF & _
"#Ограничитель 2" & @CRLF & _
"(?P>realEnd)" & @CRLF & _
"#Модификаторы шаблонов" & @CRLF & _
"#PHP [mixXsuUAJ] JavaScript [gmi] python [gmixsu]" & @CRLF & _
"((?:[mixXsuUAJ]*)|(?(?=.*?[mixXsuUAJ]+)[mixXsuUAJ]+))"
Local $sString = "test $ffsd\$ggg\\\\\\\\$iU"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")