# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?(DEFINE)
(?P<realEnd>
(?(3)\>)
(?(4)\))
(?(5)\])
(?(6)\})
(?(7)\7)
)
)
#Ограничитель 1
((\<)|(\()|(\[)|(\{)|
((?=[[:ascii:]])[^\s\w\\\)\]\}\>]))
#Шаблон
(
(?:
\\. | # что-то экранированое ИЛИ
[\w\d\s]++ | # литералы, которые не могут быть ограничителем ИЛИ
(?!(?P>realEnd)). # что угодно кроме ограничителя
)*+
)
#Ограничитель 2
(?P>realEnd)
#Модификаторы шаблонов
#PHP [mixXsuUAJ] JavaScript [gmi] python [gmixsu]
((?:[mixXsuUAJ]*)|(?(?=.*?[mixXsuUAJ]+)[mixXsuUAJ]+))
"""
test_str = "test $ffsd\\$ggg\\\\\\\\\\\\\\\\$iU"
matches = re.finditer(regex, test_str, re.VERBOSE | re.DOTALL | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.