import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\w+(?: +\\w+)*(?:\\s*, *\\w+(?: +\\w+)*)+\\s*$";
final String string = " 1000,two thousand,3000 \n"
+ "1000 , 2000 , 3000\n"
+ " First Option,2Nd Option, THIRD Option\n\n"
+ "Single Value\n"
+ "1000 ,, 2000 , 3000\n"
+ "1000 , 2000 , 3000,\n"
+ "1000 , 2000 , 3000,,\n"
+ ",,1000 , 2000 , 3000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}