const regex = /^\s*\w+(?: +\w+)*(?:\s*, *\w+(?: +\w+)*)+\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*\\w+(?: +\\w+)*(?:\\s*, *\\w+(?: +\\w+)*)+\\s*$', 'gm')
const str = ` 1000,two thousand,3000
1000 , 2000 , 3000
First Option,2Nd Option, THIRD Option
Single Value
1000 ,, 2000 , 3000
1000 , 2000 , 3000,
1000 , 2000 , 3000,,
,,1000 , 2000 , 3000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}