$re = '/^(?:([A-D])(?!.*?\1),)*[A-D]$/m';
$str = 'Some matches would be:
A
C
C,B
B,D
D,B,A,C
Some no matches would be:
A,A
ABC
D,B,A,B
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);