import re
regex = re.compile(r"^(?:([A-D])(?!.*?\1),)*[A-D]$", flags=re.MULTILINE)
test_str = ("Some matches would be:\n"
"A\n"
"C\n"
"C,B\n"
"B,D\n"
"D,B,A,C\n"
"Some no matches would be:\n"
"A,A\n"
"ABC\n"
"D,B,A,B\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")