$re = '/^\s*vertex (\d+\.\d+e[-+]\d+) (\d+\.\d+e[-+]\d+) \d+\.\d+e[-+]\d+\s*$/m';
$str = 'facet normal 4.650354e-002 -9.989174e-001 -1.217645e-003
outer loop
vertex 2.069799e+002 1.218346e-001 2.000000e+002
vertex 2.069756e+002 1.218346e-001 1.997564e+002
vertex 2.139428e+002 4.871899e-001 1.995131e+002
endloop
endfacet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);