import Foundation
let pattern = #"^\s*vertex (\d+\.\d+e[-+]\d+) (\d+\.\d+e[-+]\d+) \d+\.\d+e[-+]\d+\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
facet normal 4.650354e-002 -9.989174e-001 -1.217645e-003
outer loop
vertex 2.069799e+002 1.218346e-001 2.000000e+002
vertex 2.069756e+002 1.218346e-001 1.997564e+002
vertex 2.139428e+002 4.871899e-001 1.995131e+002
endloop
endfacet
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)