using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w+([-!#\$%&'\*\+/=\?\^`\{\}\|~]+\w+)*\@[\w+[\-+\w+]*(\.(((\w+(-+\w+)+))|\w{2,}(\.((\w+(-+\w+)+))|\w{2,})*))+$";
string input = @"a?a@2lo-pez.es.e-s";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}