re = /^\w+([-!#\$%&'\*\+\/=\?\^`\{\}\|~]+\w+)*\@[\w+[\-+\w+]*(\.(((\w+(-+\w+)+))|\w{2,}(\.((\w+(-+\w+)+))|\w{2,})*))+$/m
str = 'a?a@2lo-pez.es.e-s'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end