$re = '/.*form"$/m';
$str = 'value="something form"
value="Second cool form"
value="another silly old form"
value="blabla"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);