re = /.*form"$/m
str = 'value="something form"
value="Second cool form"
value="another silly old form"
value="blabla"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end