$re = '/\((\d+),(\d+)\)/';
$str = '"AT (1,1) ADDROOM RM0001"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);