const regex = /(.*?\d+\s+\d+\s+\d+\s*)/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?\\d+\\s+\\d+\\s+\\d+\\s*)', 'img')
const str = `AAAAAAAAAAAAAAAA 925 940 TTTTTTTTTTTTTTTT 3001 3016 15 AAAAAAAAAAAAAAAA 2418 2433 TTTTTTTTTTTTTTTT 3000 3015 15`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}