// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)(.*?\d+\s+\d+\s+\d+\s*)").unwrap();
let string = "AAAAAAAAAAAAAAAA 925 940 TTTTTTTTTTTTTTTT 3001 3016 15 AAAAAAAAAAAAAAAA 2418 2433 TTTTTTTTTTTTTTTT 3000 3015 15";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}