const regex = /(?<=EB \d{7}).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=EB \\d{7}).*', 'gm')
const str = `EB 6764589
EB 12345670000`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);