$re = '/(?<=EB \d{7}).*/m';
$str = 'EB 6764589
EB 12345670000';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;