$re = '/\d*(?:[^\w\s]+\d*)+\s*/m';
$str = '4/13/2022 2:20:03 pm from our side a more detailed analysis4 +7 (495) 797-8700 77-8282';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;