import re
regex = re.compile(r"\d*(?:[^\w\s]+\d*)+\s*", flags=re.MULTILINE)
test_str = "4/13/2022 2:20:03 pm from our side a more detailed analysis4 +7 (495) 797-8700 77-8282"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)