package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)>[^<]*<(*SKIP)(*F)|searchText`)
var str = `<div><a href="www.searchText.com">This is <a href="www.searchText.com">sentence</a> tI want to test.</a></div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}