$re = '/>[^<]*<(*SKIP)(*F)|searchText/mi';
$str = '<div><a href="www.searchText.com">This is <a href="www.searchText.com">sentence</a> tI want to test.</a></div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);